new engine is DEAD

or at least circling the drain.

turns out when hot, the oil pressure drops to 5psi. didn’t notice when buying because the oil gauge on mustangs is really just an idiot light in dial form. when the pressure is >6psi, the needle snaps to mid range and that is it.

so once again for the tenth time, transmission off, engine out! caleb lending some small hands

 

success!

 

oil pan off and removed some bearing caps to even see if it is salvageable. when this photo was taken we had 6 days to race.

mains had some waviness but no deep grooves, camera makes it look worse than it really is. Rods were very smooth, not too worried there.

it is strange these rods have no oil holes? wrist pin and bottom of piston is splash oiled only?

 

 

 

rolled in the new bearings and dropped it back into place. getting good at this now

 

drum roll please

 

 

60psi cold at 1000rpm. not great, but it should *survive*

 

back to regularly scheduled work:

different race series has different safety regs. lucky dog wants a window net, so need to weld up some brackets

and after an hour of BS fettling, net is installed. a little bit janky but should stop the major body parts from exiting the vehicle

 

 

because our car started life as a v6 and is now a v8, it did not have dual pipes or mounting hardware. chris drew the short straw and climbed up in the belly of the beast to tack it together

 

 

still plenty on the todo list…

1 thought on “new engine is DEAD”

Leave a Reply to Paraic Cancel reply

Your email address will not be published. Required fields are marked *